[Samba] Error in samba-tool dbcheck after updating to samba-4.9.1

Rommel Rodriguez Toirac rommelrt at nauta.cu
Fri Nov 9 01:37:17 UTC 2018

El 8 de noviembre de 2018 4:37:59 PM GMT-05:00, miguel medalha via samba <samba at lists.samba.org> escribió:
>On 08-11-2018 21:02, Rommel Rodriguez Toirac via samba wrote:
>>   Hello all;
>> I use CentOS 7.5.1804
>> I update from samba-4.8.2 to samba-4.9.1 and finish with not errors,
>but when I run
>> samba-tool dbcheck --cross-ncs
>> I have the error:
>> [root at gtmad ~]# samba-tool dbcheck --cross-ncs
>> Checking 4087 objects
>> ERROR(<type 'exceptions.UnicodeEncodeError'>): uncaught exception -
>'ascii' codec can't encode character u'\xe9' in position 319: ordinal
>not in range(128)
>>    File
>"/usr/lib64/python2.7/site-packages/samba/netcmd/__init__.py", line
>177, in _run
>>      return self.run(*args, **kwargs)
>>    File "/usr/lib64/python2.7/site-packages/samba/netcmd/dbcheck.py",
>line 157, in run
>>      controls=controls, attrs=attrs)
>>    File "/usr/lib64/python2.7/site-packages/samba/dbchecker.py", line
>221, in check_database
>>      error_count += self.check_object(object.dn, attrs=attrs)
>>    File "/usr/lib64/python2.7/site-packages/samba/dbchecker.py", line
>2230, in check_object
>>      error_count += self.check_dn(obj, attrname, syntax_oid)
>>    File "/usr/lib64/python2.7/site-packages/samba/dbchecker.py", line
>1324, in check_dn
>>      v_dn = dsdb_Dn(self.samdb, v.decode('utf8'))
>>    File "/usr/lib64/python2.7/site-packages/samba/common.py", line
>101, in __init__
>>      self.dn = ldb.Dn(samdb, self.dnstring)
>> (...)
>This is a known bug:

I test samba4 after the update and is working, all user are there, in DNS all PC and IP are there; I add a new record to DNS and work fine. If I let the system as are now, in next updates this problem will be solved? I can do that?
 Not fix the staft runing
samba-tool dbcheck --cross-ncs after update is a big problem?

Rommel Rodriguez Toirac
rommelrt at nauta.cu

More information about the samba mailing list