[Samba] Error running "samba-tool dbcheck" after going from 4.8.6 to 4.9.2

miguel medalha medalist at sapo.pt
Thu Nov 8 20:45:20 UTC 2018

I just tested Samba 4.9.2 on one of my DCs, previously running version 
4.8.6. Immediately after install, I ran "samba-tool dbcheck" and got the 

Checking 511 objects
ERROR(<type 'exceptions.UnicodeDecodeError'>): uncaught exception - 
'ascii' codec can't decode byte 0xc3 in position 25: ordinal not in 
line 177, in _run
     return self.run(*args, **kwargs)
line 157, in run
     controls=controls, attrs=attrs)
line 222, in check_database
     error_count += self.check_object(object.dn, attrs=attrs)
line 2315, in check_object
     expected_dn = ldb.Dn(self.samdb, "RDN=RDN,%s" % (parent_dn))

The error disappears after going back to Samba 4.8.6. The underlying OS 
is CentOS 7.4.

Although the names my users use at logon don't have accented characters, 
several of them have them in their complete names. Several of the group 
names also have accented characters.

This is likely the same error reported under Bug 13616, which meanwhile 
has been declared as closed.

More information about the samba mailing list