[Samba] Fwd: Time server on AD DC in an LXD container.

Jonathan Kreider jonathan.kreider at gmail.com
Tue Nov 6 22:48:14 UTC 2018

Thanks Robert & Marco.

@Robert - I tried your solution, but couldn't get it to work because my
host is ubuntu 16.04 and the chrony version for this is too old to support
the ntpsigndsocket option.

@Marco - your response got me searching in another direction. I had tried
ntpd in the container, which LXD did not like. My research turned up that
Ubuntu now strongly favors chrony as of 18.04 AND that chrony has been
patched to work as a time_server_ (which is what I need) in containers.

I've successfully installed chrony in the container and have setup
chrony.conf for ntpsigndsocket (and other suggested settings from
https://wiki.samba.org/index.php/Time_Synchronisation. I've also
verified/set ownership and permissions for /var/lib/samba/ntp_signd. This
appears to be the path where samba expects to find this on the Ubuntu
distribution. Is there a way to verify that this is the correct path?

I've restarted both the samba ad dc and chrony services.

However, running w32tm /resync on my W10 domain member is still not

running: C:\WINDOWS\system32> w32tm /query /source
returns only -> Local CMOS Clock

C:\WINDOWS\system32> w32tm /resync /rediscover
Sending resync command to local computer
The computer did not resync because no time data was available.
How do I further troubleshoot this? Is there a way to check on the server
whether my samba AD DC is able to provide the time service?


> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list