[Samba] Kodi crashes when trying to browse network

Rowland Penny rpenny at samba.org
Fri Nov 2 15:01:15 UTC 2018

On Fri, 2 Nov 2018 09:45:44 -0500
Michael Cronenworth via samba <samba at lists.samba.org> wrote:

> On 11/2/18 5:43 AM, L.P.H. van Belle via samba wrote:
> > Its a headless server so in this case im unable to test from within
> > kodi, atm. But Michael count try to to adjust the maxprotocol from
> > within kodi and see if that helps.
> Kodi is a GUI app. There is no "shell" or "exit to shell" feature. It
> calls library functions and does not call the "smbclient"
> command-line tool.

Yes I know now ;-)
There is a 'shell', it is called 'ssh' 

> Any changes to guisettings.xml requires entering the GUI and toggling
> the settings. I've tried setting Min Protocol to None, SMBv1, SMBv2.
> I've tried setting Max Protocol to None, SMBv1, SMBv2. No combination
> of settings works. Kodi crashes the same way (in
> libgenrand-samba4.so, opening /dev/urandom) each time.

I cannot make it crash (I have fixed my 'cannot connect' problem, I
didn't have libsmbclient installed)
> This looks like a Samba bug so I'll file it.

If it is a Samba bug, it seems to be localised to Fedora, it works on
Devuan, which means it works on Debian, Louis seems to have it working
on Ubuntu 18.04 
Using smbclient is very much like using the Kodi interface, the both
use libsmbclient


More information about the samba mailing list