[Samba] Help, DNS forwarding not working!

Ole Traupe ole.traupe at tu-berlin.de
Tue May 29 12:39:13 UTC 2018

On 29.05.2018 14:13, Rowland Penny via samba wrote:
> On Tue, 29 May 2018 14:05:23 +0200
> Ole Traupe via samba <samba at lists.samba.org> wrote:
>> Please ignore, resolved now (although I don't know why or how).
>> Strange that things always resolve only after (!) posting to this
>> list. The latter seems to work in magic ways. ;)
>> Rowland, thank you very much for your quick replay!! I was able to
>> ping the forwarder, but i wasn't able to resolve any hostnames on the
>> DCs themselves. After I restarted the samba services, the issue went
>> away. I did some changes to the smb.conf and only applied them via
>> "smbcontrol all reload-config". Seems that a complete service restart
>> was necessary for whatever reason.
> Hmm, there is a problem with Bind9, if you reload the config, it falls
> over, everybody pointed at Bind9, but now I am not so sure. Could it be
> that it is actually a Samba problem ??
> Rowland

I am not sure. I am using the internal DNS server.

So, a while ago I tried to resolve a completely different issue with DNS 
(interference by a Windows security software module with TLS encrypted 

I tried a different (valid as such) DNS forwarder and apparently entered 
an incorrect value - and applied that modification via "smbcontrol all 
reload-config". It did not have an effect, and so I forgot about it. 
Until restarting my DCs due to different reasons one after the other. 
Then I found the mistake and corrected it, but again that didn't help - 
until I realized that I need to restart the service (which was done 
implicitly via the machine reboot). So basically, I do these things not 
often enough to remember their peculiarities.

However, if DNS resolver changes should apply via "smbcontrol all 
reload-config", then there clearly is something wrong.

More information about the samba mailing list