[Samba] Change of behavior samba 3.6 and 4.5

john doe johndoe65534 at mail.com
Mon May 7 14:22:33 UTC 2018

On 5/6/2018 7:52 PM, Rowland Penny via samba wrote:
> On Sun, 6 May 2018 19:40:01 +0200
> john doe via samba <samba at lists.samba.org> wrote:
>> On 5/6/2018 1:23 PM, Rowland Penny via samba wrote:
>>> On Sun, 6 May 2018 12:51:33 +0200
>>> john doe via samba <samba at lists.samba.org> wrote:
>>>> Hi,
>>>> I'm in the process of replacing my samba server 3.6.x (Debian
>>>> wheezy, stable) to samba 4.5.x (Debian stretch, stable).
>>>> I'm facing one mageor opstacle:
>>>> When I do "net view \\<SAMBA-3-SERVER>" a list of the available
>>>> shares is displayed.
>>>> But if I do the same command "net view <\\SAMBA-4-SERVER>" I get
>>>> the following error:
>>>> "System error 5 has occurred.
>>>> Access is denied."
>>>> If I enter the username/password when prompted everything is
>>>> working as expected.
>>>> Obviously, there has been some mageor changes between samba 3.x and
>>>> samba 4.x but I can't seam to find an explanation for this
>>>> behavior.
>>>> Is there a way to get the samba 3.x behavior on samba 4.x?
>>>> In other words: why do I need to enter credentials prior  to be
>>>> able to "net view" the available shares.
>>> You don't, or at least, it works for me.
>> Thanks Rowland, for confirming that for you 'net view
>> \\<SAMBA-4-SERVER>' works without having to first enter credentials.
>>> Might help if you posted the smb.conf from 'SAMBA-4-SERVER' (and
>>> 'SAMBA-3-SERVER, if it is different)
>> For testing purposes I used the smb.conf from the working samba 3.X
>> server and still getting the same error.
>> Any other ideas?
> Yes, post the smb.conf, I (and anybody else) will not have a clue how
> you are running Samba unless you do. Just because it worked with 3.6.x
> doesn't mean it will work with 4.5.x

Here's my smb.conf (lines starting with '#',';', and blank lines are 

With the exception of the 'log file' option it's the smb.conf find in 
/usr/share/doc/samba-common/examples/smb.conf.default.gz on Debian 9.

    workgroup = MYGROUP
    server string = Samba Server
    server role = standalone server
    log file = /var/log/samba/log.m
    max log size = 50
    dns proxy = no
    comment = Home Directories
    browseable = no
    writable = yes
    comment = All Printers
    path = /usr/spool/samba
    browseable = no
    guest ok = no
    writable = no
    printable = yes

Prior to enter credentials if I do 'net use ...' I get the following:

PS> net use \\<SAMBA-SERVER>
The password or user name is invalid for \\<SAMBA-SERVER>.

Enter the user name for '<SAMBA-SERVER>': john
Enter the password for <SAMBA-SERVER>:
The command completed successfully.


Thanks Rowland or to anyone else that is able to help me.

Any help is much appriciated! :)

John Doe

More information about the samba mailing list