[Samba] samba 4 joining samba 3 pdc - group mismatch

Rowland Penny rpenny at samba.org
Thu May 3 18:18:45 UTC 2018

On Thu, 3 May 2018 14:59:18 -0300
"Ethy H. Brito via samba" <samba at lists.samba.org> wrote:

> I run the pdbedit command.
> I got a lage amount of users (and groups). 
> The admin of the S3 server deleted (userdel) 75 users and these are
> still listed by pdbedit. How do I get rid os them??
> I think you may be mistaken (or I did not fully understood your
> affirmation). These "no such user" users were deleted from Linux with
> "userdel -r"  and are ghosts in Samba.
> I just tried to remove them (smbpasswd -x) them but got "Failed to
> delete entry for user XXXX"
> How do I get rid of these ghosts?

The OS stores users in /etc/passwd and userdel removes these, but there
are also Samba users and you need to run 'smbpasswd -x username' to
remove these.

> > what is your rsync command ?
> for i in D1 D2 D3 D4 ; do 
>         echo
>         echo "SYNC'ing $i";
>         echo
>         /usr/bin/rsync -av S3:/var/samba/$i /home; 
> done
> > I ask this because if I rsync a file from my pc (rowland, 10000, ad
> > backend) to a another pc (rowland, 11107, rid backend), ls -la shows
> > the owner as 'rowland'
> Maybe you mounted the remote server locally. Didn't you?

My rsync command was much the same as yours (just added 'z') and I
didn't mount anything, which leads to the next question, are you
mounting anything ?


More information about the samba mailing list