[Samba] cannot compile 4-8-stable or 4-8-test

Andrew Bartlett abartlet at samba.org
Tue May 1 21:02:52 UTC 2018

On Tue, 2018-05-01 at 16:29 -0400, Sonic via samba wrote:
> Samba from git (4-8-stable and 4-8-test) is failing to compile. I did
> not have these issues with the previous 4-7 branches.
> Basically this installation is just a simple file server, no domain,
> ad, print service, etc. necessary or even desired.
> My configure arguments:
> $ ./configure --without-winbind --disable-avahi --without-ads
> --without-ldap --without-pam --without-quotas --without-dnsupdate
> --without-automount --without-ad-dc --with-systemd --enable-gnutls
> --without-ntvfs-fileserver --accel-aes=intelaesni
> If I drop "--without-ldap" the compile is successful but I have no
> need for ldap in the installed environment and I see no reason that
> anything to do with GPO would be necessary when the configure includes
> "--without-ads --without-ldap --without-ad-dc".
> Seems to be a mistake that libgpo/pygpo.c is even attempted as part of
> the make in such an environment.

That command worked for me in git master, so if it bothers you
particularly please file the commit that fixed it, file a bug and
attach it for backport (cherry-pick with git cherry-pick -x).

In the meantime I'll look at including the --without-ldap part of that
combination in our autobuild scripts so it won't regress in the future.


Andrew Bartlett
Andrew Bartlett
Authentication Developer, Samba Team         https://samba.org
Samba Development and Support, Catalyst IT   

More information about the samba mailing list