[Samba] Samba NT4 to AD- LDAP

Praveen Ghimire PGhimire at sundata.com.au
Sat Mar 24 11:59:38 UTC 2018

Hi All,

Following the link, tried to migrate NT4 to AD using LDAP but came across some issues.

I have done this step multiple times using TDB as the backend and it has always worked.

The issue I am seeing is when I run the following, we get
samba-tool domain classicupgrade --dbdir=/var/lib/samba.PDC/dbdir --realm=LIN.GROUP --dns-backend=SAMBA_INTERNAL /etc/samba.PDC/smb.PDC.conf

Next rid = 10003
ERROR(<type 'exceptions.IndexError'>): uncaught exception - list index out of range
  File "/usr/lib/python2.7/dist-packages/samba/netcmd/__init__.py", line 175, in _run
    return self.run(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/samba/netcmd/domain.py", line 1460, in run
    useeadb=eadb, dns_backend=dns_backend, use_ntvfs=use_ntvfs)
  File "/usr/lib/python2.7/dist-packages/samba/upgrade.py", line 664, in upgrade_from_samba3
    urls = samba3.lp.get("passdb backend").split(":",1)[1].strip('"')

I'm running the upgrade on PDC (LDAP) server .

       local master = yes
        domain master = yes
        preferred master = yes
        domain logons = yes
        os level = 65

  passdb backend = ldapsam
  ldap admin dn = cn=admin,dc=lin
  ldap suffix = dc=lin
  ldap group suffix = ou=groups
  ldap machine suffix = ou=computers
  ldap user suffix = ou=users
  idmap backend = ldap
  ldap idmap suffix = ou=idmap
  idmap config *: backend = ldap
  idmap config *: range = 10000-19990
  idmap config *: ldap_url = ldap://lin-pdc.lin/   (Also tried //localhost)
  idmap config *: ldap_base_dn = ou=idmap,dc=lin
  idmap config *: ldap_user_dn = cn=admin,dc=lin
  ldap delete dn = yes
  ldap password sync = yes

The only thing I can think of is when running the smbldap-popluate we used the following,
smbldap-populate -g 10000 -u 10000 -r 10000

Samba version 4.6.7 (Ubuntu 16.04)

Can anyone please advise?


Praveen Ghimire

More information about the samba mailing list