[Samba] Internal DNS migrate to Bind9_DLZ

Eben Victor eben.victor at gmail.com
Mon Jul 30 08:41:14 UTC 2018


I hope that someone can perhaps assist me or just guide me in the right

I've been following all the steps for setting up and migrating my Samba
Internal DNS to Bind9_DLZ.

But this doesn't seem to work for me, I can get bind started up 100% when I
remove include "/var/lib/samba/bind-dns/named.conf" from named.conf, but as
soon as I add this line back then everything fails with below error.

30-Jul-2018 10:26:39.719 generating session key for dynamic DNS
30-Jul-2018 10:26:39.719 sizing zone task pool based on 3 zones
30-Jul-2018 10:26:39.722 Loading 'AD DNS Zone' using driver dlopen
30-Jul-2018 10:26:40.026 samba_dlz: started for DN DC=domain,DC=corp
30-Jul-2018 10:26:40.027 samba_dlz: starting configure
30-Jul-2018 10:26:40.049 dns_rdata_fromtext: buffer-0x7facd1f60dc0:1: near
eof: unexpected end of input
30-Jul-2018 10:26:40.049 Failed to put rr
30-Jul-2018 10:26:40.269 zone domain.corp/NONE: has 0 SOA records
30-Jul-2018 10:26:40.269 zone domain.corp/NONE: has no NS records
30-Jul-2018 10:26:40.270 samba_dlz: Failed to configure zone 'domain.corp'
30-Jul-2018 10:26:40.270 loading configuration: bad zone
30-Jul-2018 10:26:40.270 exiting (due to fatal error)
30-Jul-2018 10:26:40.271 samba_dlz: shutting down

domain.corp is just an alias, not the actual domain name.

I even tried the migration by removing ALL reverse & forwarded zones but
still no luck.

Version 4.8.3-SerNet-RedHat-11.el7
Red Hat Enterprise Linux Server release 7.5 (Maipo)
BIND 9.9.4-RedHat-9.9.4-61.el7 (Extended Support Version)

Kind Regards

More information about the samba mailing list