[Samba] passdb.error: uncaught exception - requested file lock

Andrew Bartlett abartlet at samba.org
Thu Jul 26 03:49:37 UTC 2018

On Thu, 2018-07-26 at 15:33 +1200, Mario Codeniera via samba wrote:
> Background:
> I tried to upgrade our existing server using classicupgrade previously
> working before with the previous version but because it was pending in a
> couple of months as working with other projects.
> Currently using with Samba 4.8.3 in Fedora 28, I don't know if it relates
> to the previous version (4.7.x, which I used before) as I upgrade the
> distro. I tried to delete the said account, then another account or machine
> will appear with the same error up to 10 tries, I stop as kept appearing.
> As Fedora 28 don't have samba 4.7.x version, will try to recreate the
> server on a separate machine if this will resolve the issue.

Samba 4.8.3 is fine, but Fedora packaged Ldb 1.4.0 which breaks Samba.

ldb 1.4.1 will prevent this from happening at build time, but in the
meantime we have an unfortunate situation. 


Andrew Bartlett

> Thanks.
Andrew Bartlett
Authentication Developer, Samba Team         https://samba.org
Samba Development and Support, Catalyst IT   

More information about the samba mailing list