[Samba] Fwd: Problem connecting to DC from windows 10. Failed to create user record ... acl: unable to get access to ...

Rowland Penny rpenny at samba.org
Wed Jul 25 16:36:02 UTC 2018

On Wed, 25 Jul 2018 08:55:01 +0200
Andrzej Gryko via samba <samba at lists.samba.org> wrote:

> Avahi is not running.
> My smb.conf:
> # Global parameters
> [global]
>         netbios name = SAMBA
>         realm = GRYKO.LOCAL
>         server services = s3fs, rpc, nbt, wrepl, ldap, cldap, kdc,
> drepl, winbindd, ntp_signd, kcc, dnsupdate
>         workgroup = GRYKO
>         server role = active directory domain controller
> [netlogon]
>         path = /var/lib/samba/sysvol/gryko.local/scripts
>         read only = No
> [sysvol]
>         path = /var/lib/samba/sysvol
>         read only = No
> I didn't tell that I ran debian on Microsoft Hyper-V machine, I try to
> connect to DC typing "gryko.local" as a domain in win 10 system
> properties, and next typing username and password (also I type
> domainname\username and password).
> I installed two virtual machines and on both there is the same error
> in log.samba.
> I installed samba by: " *apt-get install samba smbclient bind9
> krb5-user" and next I installed winbind by apt-get too.*

So you are trying to log into the DC as a user, then you need some more
packages installed.

attr libpam-winbind libpam-krb5 libnss-winbind krb5-config ntp bind9utils
Note: some of these may already be installed.

By default, you cannot log into a DC


More information about the samba mailing list