[Samba] Peculiar Problem with DNS

Rowland Penny rpenny at samba.org
Fri Jul 6 06:19:59 UTC 2018

On Fri, 6 Jul 2018 08:29:29 +0530
Anantha Raghava via samba <samba at lists.samba.org> wrote:

> Hi,
> I have hit a very peculiar problem with DNS.
> We are using BIND9 as DNS with Samba (Ver 4.7.5). Off late we added a 
> new A record into one of the Zones using RSAT. It is not visible
> either through RSAT or when we query using samba-tool. We search
> using RSAT or samba-tool, it results in '0' matches.
> However, when we attempt make a new entry with same name and IP, it 
> reports an error "Record already exists". But we attempt to delete
> using samba-tool (RSAT since it is not visible, we cannot do
> anything), it reports '0' matching record.
> We checked in all 4 Domain Controllers, it is the same result.
> We add any other record, it works just fine, we are able to see it in 
> RSAT and samba-tool also reports & works properly. Just this record,
> is throwing up an peculiar error.
> Is there a method we search for this record in the database and
> remove it?

have you tried using 'nsupdate' to remove it ?

failing that:

ldbedit --cross-ncs --show-binary -e nano -H /var/lib/samba/private/sam.ldb

and search for the record.


More information about the samba mailing list