[Samba] Issues accessing ZFS-shares on Linux

John Doe aurinko at asauna.io
Wed Jan 10 02:51:23 UTC 2018

I just noticed that by running by commands /usr/sbin/smbd -D or
/usr/sbin/smbd -i without systemd's unit, all shares work perfectly so
the problem must then be somehow related to systemd.. Let the testing

I also tested what happens if I comment out everything and just use
ExecStart=/usr/sbin/smbd -D as that command worked on the console. That
did not help.

For the record, this is the default unit-file:
Description=Samba SMB Daemon
Documentation=man:smbd(8) man:samba(7) man:smb.conf(5)
After=network.target nmbd.service winbind.service

ExecStart=/usr/sbin/smbd $SMBDOPTIONS
ExecReload=/bin/kill -HUP $MAINPID


Jeremy Allison via samba kirjoitti 9.1.2018 klo 21:47:
> On Tue, Jan 09, 2018 at 07:57:41AM +0200, John Doe via samba wrote:
>> I added one testshare /home/testijako and connected to it with the same
>> credentials as I would connect to ZFS-shares. Then I did the strace to
>> that particular PID and tried connecting to one ZFS-share. There was
>> indeed an error which might have something to do with this issue:
>> Line 2001: lstat("/tank/rex", 0x7fff1f6fb2c0)      = -1 ENOENT (No such
>> file or directory)
>> Im sure that folder exists (files have been omitted):
>> aurinko at punishedkorppu:~$ cd /tank/rex
>> aurinko at punishedkorppu:/tank/rex$ ls -hal
>> total 32M
>> drwxrwxrwx   12 rex     rex       20 Dec 24 19:09  .
> Well that looks like your issue. You need to figure
> out why  lstat("/tank/rex") is failing on an existing
> directory.

More information about the samba mailing list