[Samba] samba-tool drs showrepl Issues After updating to 4.5.15

David Minard david at scem.westernsydney.edu.au
Wed Jan 10 00:13:54 UTC 2018

G'day All,

     We have a test and production SambaAD running very happily, but 
they are many versions out of date. We need to upgrade.

     Both versions of Samba are currently running 4.3.2.

     Our test SambaAD runs on Centos6 with two DCs running in the same 
data centre.

     Our production SambaAD runs on Centos7 with 4 DCs across 4 
geographically dispersed data Centres.

     I went about updating the test SambaAD by installing Samba4.3.13, 
testing everything, and all was well.

     Then I moved onto Samba4.4.16, and again everything worked well.

     However, when I went to Samba4.5.15, and did:

samba-tool drs showrepl, on the DC with all the FSMO roles failed with 
TIMEOUT issues more than 50% of the time. It never failed with previous 

     Being a VM, I reverted the test SambaADs back to 4.4.16, just to 
make sure that showrepl worked fine, and it did.

     Being curious, I have since moved forward in version, 4.4.16 --> 
4.5.15 --> 4.6.11 --> 4.7.3.

     The results of showrepl; 4.5.15, still flaky. 4.6.11, still flaky. 
4.7.3, works every time, but really really slowly.

     Throughout this process, on the nonFSMO DC showrepl works every 
time, and very quickly.

     So my questions are:

     What was different in 4.5.x that might have caused this issue?

     Given that 4.7.x seems to have showrepl working, although 
excessively slowly, is it a concern?

     Obviously before I start updating the production SambaAD, I need to 
be sure I will not break things.


[Sometimes waking up just isn't worth the insult of the day to come.]

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the samba mailing list