[Samba] dhcpd create lease error and unable to kinit for dynupdate on domain controller

Rowland Penny rpenny at samba.org
Fri Jan 5 14:37:52 UTC 2018

On Fri, 5 Jan 2018 14:03:58 +0000
niya <niyalevi at gmail.com> wrote:

> Hi Rowland
> thank for the quick reply
> i did try the version from the samba wiki first which failed when 
> getting a new ticket ,
> dhcpd kinit for dynamic dns failed,
> so i tried the arch linux version next,
> i asked in the arch -general list but i got no answers so i tried
> samba, as my dhcpd is working apart from renewing the lease file
> is there another solution to the dynamic dns update orĀ  should i
> leave it as it is until a fix is found for the problem.
> i may be wrong but both the issues seem to be because dhcpd drops
> root privilage after boot ,
> anything further than that i can't say.
> Shadrock
> so should i just give up on

I cannot help with the arch script, but possibly I can help with the
script found on the Samba wiki.
The Samba script was written to be used with debian and here dhcpd
runs as root. It would seem that another way needs to be found to
update the kerberos ticket, perhaps in root's crontab ?


More information about the samba mailing list