[Samba] SAMBA failed join domain DC

Rowland Penny rpenny at samba.org
Wed Feb 21 08:59:05 UTC 2018

On Wed, 21 Feb 2018 10:45:43 +0500
"denis.shigapov" <denis.shigapov at stroylandiya.ru> wrote:

> Not join
> samba-tool domain join EXAMPLE DC -Uvas.lah --password=password
> --realm=EXAMPLE.RU --site=SITE2 find srv-site3-dc01 and the same
> error occurred
> samba-tool domain join EXAMPLE DC -UAdministrator --password=password
> --server=srv-dc01.example.ru --realm=EXAMPLE.RU --site=SITE2 returned
> the original error
> vas.lah - domain administrator
> also tried the user with the rights: enterprice admins and scheme
> admins
> Samba 4.6 previously tried and joined the domain, but due to
> replication errors it was abandoned

Is there some reason why you will not try the exact join command I
posted ???

I can assure you that the join command works on 4.7.5, I did it last
Friday, albeit against a Samba AD DC.

You shouldn't get replication errors, perhaps the problem lies on the
windows DC you are trying to join to ? 


More information about the samba mailing list