[Samba] getpwuid failed for single user on single file share

Rowland Penny rpenny at samba.org
Wed Feb 14 20:35:01 UTC 2018

On Wed, 14 Feb 2018 20:43:20 +0100
Arne Zachlod via samba <samba at lists.samba.org> wrote:

> > If you run 'smbclient -L adfs02.int.becit.de -U
> > brokenuser at int.domain' on 'adfs02', does this work
> no, same error:
> root at adfs02:~# smbclient -L adfs02.int.domain -U brokenuser at int.domain
> Enter brokenuser at int.domain's password:
> session setup failed: NT_STATUS_UNSUCCESSFUL
> but I forgot the most important part, in /var/log/samba/__1.log on
> adfs02 it says:
> [2018/02/14 18:51:29.614082,  1]
> ../source3/auth/token_util.c:430(add_local_groups)
>   SID S-1-5-21-456140246-2344957557-3140247660-1174 -> getpwuid(10026)
> failed
> [2018/02/14 18:51:29.614128,  1]
> ../source3/smbd/sesssetup.c:282(reply_sesssetup_and_X_spnego)
>   Failed to generate session_info (user and group token) for session
> > Have you tried changing the password again ?
> I don't know exactly what the user did, but I changed the password
> afterwards (as in after the bug report) and it works on our other
> fileshares, just not on adfs02.

This sounds like a problem with something on the fileserver, have you
tried running 'net cache flush' on the fileserver and/or restarting
Samba and/or the fileserver ?

There have been a couple of problems similar to this and if I remember
correctly, the problem ended up getting fixed by deleting the user and
re-creating it.


More information about the samba mailing list