[Samba] Using MS-DOS client

Rowland Penny rpenny at samba.org
Tue Dec 25 14:53:07 UTC 2018

On Tue, 25 Dec 2018 09:34:00 -0500 (EST)
Steven Hirsch via samba <samba at lists.samba.org> wrote:

> On Tue, 25 Dec 2018, Rowland Penny via samba wrote:
> > On Mon, 24 Dec 2018 15:37:45 -0800
> > Luke Barone via samba <samba at lists.samba.org> wrote:
> >
> >> Try adding "server max protocol = nt1" in the [global] section?
> >> 
> >
> > This should probably have been 'client max protocol = CORE'
> >
> > If this works, then read in 'man smb.conf' about 'client max
> > protocol' and raise the level until it stops working, then use the
> > last level that works.
> Thanks for the suggestions.  I had already tried that as well, but
> with no success.  Even after many re-reads I admit to a complete lack
> of understanding as to what 'server max/min ..' and 'client
> max/min ..' are actually doing.  If I squint with one eye, it looks
> like client impacts the operation of smbclient on the local machine,
> but your statement implies something quite different.  As I said, no
> combination of these settings helped.
> > I would also suggest you find a away of moving from DOS, at some
> > point it is highly likely that the old auth methods will be removed.
> That will be the point when I stop updating my server.  I understand
> the march of progress, but it is not practical for me to get caught
> up in it at the expense of losing network connectivity from my shop
> computers.
> But!
> I finally solved the problem.  After removing everything samba
> related from the platform, I spent an hour or two unsuccessfully
> trying to build an older version from source.  When that threatened
> to lead me into dependency hell, I gave up and reinstalled the
> original samba.  After restart, it began to cooperate using my
> original configuration!
> Nothing like this sort of thing to make one doubt one's own sanity.
> Upon digging a bit deeper, I _suspect_ the sudden cooperation is due
> to my not reinstalling everything (e.g. winbind) that was there from
> the original Ubuntu roster.  I'm not about to verify this theory by
> trying to break anything again and am just thankful to have
> functionality back.
> Thanks to those who chimed in and tried to help!

No, you didn't forget to install winbind, installing samba used to
install it for you, but now it doesn't and your PDC needs winbind, I
should have asked about that :-(


More information about the samba mailing list