[Samba] Missing 'glusterfs.so' in Ubuntu

Neil Richardson (mail filter) g7vnqxbwx3 at liamekaens.com
Wed Dec 5 00:08:49 UTC 2018

Hi, guys.  I'm new to all of this and need some help with a problem
I've been banging my head against for a while.  (Tried
troubleshooting, checking logs, and lots of Googling for a few weeks
now, but just keep hitting dead ends.)

Missing file `/usr/lib/x86_64-linux-gnu/samba/vfs/glusterfs.so`, as
evidenced by error messages like these:

[2018/11/18 07:56:42.551587,  0] ../lib/util/modules.c:49(load_module)
  Error loading module
/usr/lib/x86_64-linux-gnu/samba/vfs/glusterfs.so: cannot open shared
object file: No such file or directory
[2018/11/18 07:56:42.551652,  0]
  error probing vfs module 'glusterfs': NT_STATUS_UNSUCCESSFUL
[2018/11/18 07:56:42.551694,  0]
  smbd_vfs_init: vfs_init_custom failed for glusterfs
[2018/11/18 07:56:42.551729,  0]
  vfs_init failed for service music

I tried `apt get' with `samba-vfs-glusterfs' (which supposedly is
correct under yum/Debian) and `samba-vfs-modules' but it doesn't get
installed.  (I also install ctdb, winbind, smbd, and
samba-common-bin, and `samba').

I tried searching pkgs.org but it can't find that file anywhere (or
else I'm somehow doing it wrong).

The documentation at
says that it's part of Samba (which people on the Gluster mailing
list also said).

Do I need to build this myself or something?  Does the order of
installation under `apt' install different things and I just need to
reorder the parameters?  What am I missing?

Ubuntu 16
Samba 4.7.6-UBUNTU

Thank you,
-Neil R.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 885 bytes
Desc: OpenPGP digital signature
URL: <http://lists.samba.org/pipermail/samba/attachments/20181204/30519ab1/signature.sig>

More information about the samba mailing list