[Samba] Replicate with --full-sync error

Taner Tas taner76 at gmail.com
Fri Aug 31 08:40:09 UTC 2018


I tried to replicate two DC's (on test setup) with "--full-sync" option
but fails with error message below. I tried "--full-sync" because I
wonder if it has any effect on some diverged entries reported
by "samba-tool ldapcmp".

# samba-tool drs replicate dc1 dc2 --full-sync DC=samdom,DC=com

ERROR(<class 'samba.drs_utils.drsException'>): DRS connection to dc1
failed - drsException: DRS connection to dc1 failed: (3221225653,
'{Device Timeout} The specified I/O operation on %hs was not completed
before the time-out period expired.') File
"/usr/lib/python2.7/dist-packages/samba/netcmd/drs.py", line 44, in
drsuapi_connect (ctx.drsuapi, ctx.drsuapi_handle,
ctx.bind_supported_extensions) = drs_utils.drsuapi_connect(ctx.server,
ctx.lp, ctx.creds) File
"/usr/lib/python2.7/dist-packages/samba/drs_utils.py", line 58, in
drsuapi_connect raise drsException("DRS connection to %s failed: %s" %
(server, e))

Same command without "--full-sync" option doesn't give this error.

Both DC's Samba 4.8.4
Ubuntu 18.0.4

Taner Tas

More information about the samba mailing list