[Samba] Samba4 DC JOIN in renamed domain exception WERR_DS_DIFFERENT_REPL_EPOCHS

Andrea Veroni a.veroni at grafspa.it
Thu Aug 2 10:00:56 UTC 2018

Hi all,

I am trying to join a Samba 4.8.3 server running on CentOS7 as RODC to a W2008r2 domain that has been renamed in the past, thus having the flag ms-DS-ReplicationEpoch set to 1, but I am getting this error:

[user at machine ~]# samba-tool domain join example.com RODC -U"EXAMPLE\administrator" --dns-backend=SAMBA_INTERNAL
Join failed - cleaning up
ERROR(runtime): uncaught exception - (8593, 'WERR_DS_DIFFERENT_REPL_EPOCHS')
  File "/usr/lib64/python2.7/site-packages/samba/netcmd/__init__.py", line 176, in _run
    return self.run(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/samba/netcmd/domain.py", line 706, in run
  File "/usr/lib64/python2.7/site-packages/samba/join.py", line 1482, in join_DC
  File "/usr/lib64/python2.7/site-packages/samba/join.py", line 1383, in do_join
  File "/usr/lib64/python2.7/site-packages/samba/join.py", line 927, in join_replicate
  File "/usr/lib64/python2.7/site-packages/samba/drs_utils.py", line 313, in replicate
    (level, ctr) = self.drs.DsGetNCChanges(self.drs_handle, req_level, req)

Tried joining the domain as DC but same error.

Is joining to renamed domains not supported or am I doing something wrong?

Andrea Veroni
Via Galilei, 32/36
41015 Nonantola (MO), Italy
Tel. +39 059545111
Fax +39 059541272
web: http://www.grafspa.it

More information about the samba mailing list