[Samba] re: access domain via ldap failed

Rowland Penny rpenny at samba.org
Mon Apr 23 13:06:21 UTC 2018

On Sat, 21 Apr 2018 10:08:46 +0800 (CST)
Ryan <ryanyang51 at 163.com> wrote:

> I tried 'domain\username' in adexplorer as you say.But it doesn't
> work, too. It's the same warning. Do you remember I've ever mentioned
> that when I try to join the domain it succeed but still warned
> 'change the primary domain dns name of this computer to "" failed.
> the rpc server is unavailable.' I tried this in windows 7 and
> windows8.1, bath gave this warning. Do you get any clue from this for
> my problem? Thanks.

OK, I found that the Win10 machines I was using were not '1709', one
was '1511', the other '1607'

Why is windows update so c**p ???
I tried to update the '1511' machine to 1709, but, what ever I tried, it
failed, so I moved to the '1607' machine. this failed to update several
times until, for no reason what so ever, it decided to work.

I can connect using to Ad using adexplorer on the 1709 machine just as
before i.e. I have to specify the DOMAIN with the username.

All I can suggest is, leave the domain on the windows machine, check
that it is a member of the same dns domain as the AD DC and then
re-join the domain. What ever the problem is, it doesn't seem to be a
Samba problem.


More information about the samba mailing list