[Samba] Newer SMBTREE versions don't find all systems.

David F. df7729 at gmail.com
Mon Sep 18 02:17:47 UTC 2017

I should point out the config for the build for these three utilities are:

./configure --disable-cups --without-ad-dc
--sysconfdir=/etc/samba/ --localstatedir=/var/run/samba

Only need the client side.

On Sun, Sep 17, 2017 at 7:12 PM, David F. <df7729 at gmail.com> wrote:
> Hi,
> Trying the latest version again tonight 4.6.7 it has the same problem
> I've seen with the prior newer versions as well.  The one I went back
> to was 4.4.15 which works.   What is happening right now is there is a
> Win2K3 box that is the domain server, with thecompanydomain.com
> (NetBIOS domain name: COMPANY).   That has the __MSBROWSE__ on it.  I
> have a Linux Wheezy system on that is part of WORKGROUP and that also
> has the __MSBROWSE__ on it.     On Win7 which is a member of the
> COMPANY domain and view network I see the PC1, PC2, I see the Wheezy
> machine, see another one that is a VM, See the main domain server,
> another terminal server, and a Win2K8R2 sever in a VM with SMBv1
> disabled, and a NAS device.
> When I run smbtree -N -S using the 4.4.15 version from another system,
> I get WORKGROUP showing then indented under it are the two Wheezy
> systems (VM and machine), the NAS, and the Win2K8R2 sever with SMBv1
> disabled, then COMPANY and indented under that is the main domain
> server.
> When I run smbtree -N-S using the more current versions say 4.6.7, I
> see the same stuff under WORKGROUP then again COMPANY shows, but
> nothing under it.
> This is the same even if "client max protocol=SMB3" is in the config file.
> I have another person who sees nothing when the "client max
> protocol=SMB3" is in there with the 4.4.15 version.  If he removes
> that line, then smbtree shows his systems.
> Also, trying to manually access shares on the Win2K8R2 server here,
> using 4.4.15 and 4.6.7, it will not work unless "client max
> protocol=SMB3" is in the conf file.  If it's in there I can see the
> shares, if not, no shares are shown?
> So something happened at least with smbtree, and having to have the
> max protocol for accessing the shares conflicts with another person
> who can't see any systems if that is in there.
> This usage is on boot media that goes from different networks so it
> needs to have the samba tool just work, but it's not that simple.  Any
> ideas what's going on?
> TIA!!

More information about the samba mailing list