[Samba] ADC 4.7.0 KCC replication failing with PDC 4.6.8

Rowland Penny rpenny at samba.org
Fri Oct 27 16:41:03 UTC 2017

On Fri, 27 Oct 2017 18:24:50 +0200
"Kukreja H.Kukreja" <h.kukreja at ium.edu.na> wrote:

> I do have GPO directories under sysvol which I have copied using
> rsync to the new DC and when I run samba-tool ntacl sysvolreset
> command is failing on the new DC.

This usually happens when you have extra GPOs stored in Sysvol, they
are also in AD, so the command thinks they exist, but cannot find them
on disc, hence '(No such file or directory)'

If you have correctly synced the contents of the 'sysvol' directory and
idmap.ldb from the old DC to the new DC, then it should work.

> I am not sure what do I call the main DC thats why I use PDC.

How about 'DC' ?
All DCs are equal except for the FSMO roles and they can be shared out
amongst several DCs, they do not all have to be on the same DC.
Please do not call a DC a 'PDC', a PDC is something else entirely and
calling an AD DC a PDC can lead to confusion ;-)

> I have removed the unnecessary lines from smb.conf
> Please let me know what do I have to do now. I want to migrate the
> old DC running on Ubuntu 12.04 to the new DC on Ubuntu 16.04.

Are you still getting the same error ?


More information about the samba mailing list