[Samba] sysvolcheck on fresh samba 4.7 DCs

Rowland Penny rpenny at samba.org
Thu Oct 26 10:35:42 UTC 2017

On Thu, 26 Oct 2017 12:09:55 +0200
mj via samba <samba at lists.samba.org> wrote:

> Hi Andrew and Louis,
> Found the issue: after rsync-ing the sysvol from our old
> decommissioned DCs, the sysvolreset/sysvolcheck DO work out.
> I tried to keep the things simple first, by NOT immediately importing 
> our old sysvol contents, but first check with a default sysvol...
> I thought that the sysvolreset would just reset whatever is located 
> under samba/sysvol, but I guess that it reads the directories from
> the database.
> Once the on-disk directories matched the sam database contents,
> things worked fine.
> Sorry... :-|
> MJ

No, don't be sorry, you have raised a valid point, one that I was
trying to get across. If you join a DC and there are more than the
default GPOs in sysvol on the other DCs, you will get this problem
because the GPOs are also in AD and the GPOs in AD are replicated, but
the GPOs in sysvol aren't.

Now that you have fixed your DCs, never run sysvolcheck or sysvolreset
again, they are broken.


More information about the samba mailing list