[Samba] NT_STATUS_INTERNAL_ERROR from RPC server on samba 4.5.8 AD DC

Rowland Penny rpenny at samba.org
Mon Oct 16 16:26:29 UTC 2017

On Mon, 16 Oct 2017 17:01:29 +0100
Richard Connon via samba <samba at lists.samba.org> wrote:

> To try and narrow down this issue I tried to setup a test environment 
> using two fresh install Debian 9.2 VMs, now running samba 4.5.12
> since it was updated in Debian.
> I provisioned a new domain using `samba-tool domain provision` on the 
> first VM, let it generate the smb.conf itself, and configured it
> using the BIND9_DLZ DNS backend.
> I tried to join the domain using a second Debian 9.2 VM using `net
> ads join -UAdministrator` after setting the DNS resolver to be the
> test DC and synchronising with NTP on the DC. This failed with the
> error:
> "Failed to join domain: failed to lookup DC info for domain 
> 'ADS.TEST.LOCAL' over rpc: An internal error occurred."
> Finally, I tried to connect to RPC on the DC using `rpcclient` which 
> failed, as before, with NT_STATUS_INTERNAL_ERROR.
> Is there some inherent problem with the Debian packages and the RPC 
> server component of the DC? Alternatively, is there somewhere else I 
> should be looking for the root cause of this?

This isn't a known problem with the debian packages, it should work.

Can you post the provision command you used on the DC.

I know you posted the smb.conf from a DC before, but can you post it

Can you post the following files:

From both the DC and the domain member

The named.conf files from the DC

and finally the smb.conf from the domain member.


More information about the samba mailing list