[Samba] RSAT Print Management won't show shared printers underthe "Printers" section

Thomas Keppler winfr34k at gmail.com
Wed Oct 11 21:28:19 UTC 2017


> Happend in Windows 7 64bit, i havent tested win10 since i dont have one ready for management. 
> So if someone has, and also has this problem, please test and report back also. 
On Windows 8.1 and 10 it has always worked for me.

Guys, I seem to have the "solution":

Out of curiosity, I activated WINS on the DC by adding those lines to the smb.conf (the rest of the file was the auto generated one from the DC promotion):
------------ 8< ------------
wins support = yes
name resolve order = wins lmhosts hosts bcast
local master = yes
preferred master = yes
domain master = yes
os level = 255
------------ >8 ------------

...and by extending my DHCP config like so ( is my DC):
------------ 8< ------------
subnet netmask {
  option netbios-name-servers;
------------ >8 ------------ 

net view on Windows 7 did not immediately want to work, for some reason I had to enable network discovery in the "Advanced file sharing settings" like so: https://imgur.com/9wdFLpC <https://imgur.com/9wdFLpC>

Et voilĂ , printers!
https://imgur.com/jUpqt53 <https://imgur.com/jUpqt53>

My final smb.conf on the printserver is:
------------ 8< ------------
security = ADS
workgroup = EXAMPLE

log file = /var/log/samba/%m.log
log level = 1

idmap config * : backend = tdb
idmap config * : range = 10000 - 19999
idmap config EXAMPLE : backend = rid
idmap config EXAMPLE : range = 1000000 - 1999999

winbind enum users = yes
winbind enum groups = yes
winbind use default domain = yes
winbind refresh tickets = yes

template homedir = /home/%D/%U
template shell = /bin/bash

client use spnego = yes
client ntlmv2 auth = yes
encrypt passwords = yes
restrict anonymous = 2

domain master = no
local master = no
preferred master = no
os level = 0

load printers = yes
rpc_server:spoolss = external
rpc_daemon:spoolssd = fork

path = /var/spool/samba
printable = yes
printing = CUPS

comment = Print drivers
path = /var/lib/samba/drivers
create mask = 0775
inherit permissions = yes
guest ok = no
read only = no
------------ >8 ------------

Adding a new printer in CUPS works like a charm. After about 15min of waiting, the printer appears in the Print Management console.

NOTE: I didn't have to do ANY of this on Windows 8.1/10, including I didn't need WINS on those systems. The Windows 7 machine I used was up-to-date (even with the KB installed mentioned by Louis).

I will try to setup Samba once again using that config from scratch (DC, fileserver and printserver) on the weekend to see if it's solved now for me. That will also be the test to determine if I write a bug report or instead improve the documentation at this point because right now, it just seems like Windows 7 is a bit picky of whom it's talking to.

@Louis, @Marc: Can you two please test out the setup using WINS, making sure to enable the network discovery and file sharing on Windows 7? I would be really interested to see if that fixes your problems, too.

Thank you!

Best regards

More information about the samba mailing list