[Samba] Cannot use Print Server functions in NT4 style domain

Luke Barone lukebarone at gmail.com
Tue May 30 22:09:56 UTC 2017

Yes, down to a T:

# smbd -b | grep "HAVE_CUPS"

CUPS is setup, and I can print test pages from the web portal.

Created the spool directory, and applied permissions:
/var/spool# ls -lah
total 48K
drwxr-xr-x 10 root        root        4.0K Mar 17  2016 .
drwxr-xr-x 15 root        root        4.0K Jan 11  2016 ..
drwxrwxrwt  2 root        root         12K May 30 14:48 samba

Turned off "load printers"

Created the share definition for the shared printer (same name as in CUPS).
Verified the permissions for managing the printers:
# net rpc rights list privileges SePrintOperatorPrivilege -U "JMC\lbarone"
Enter JMC\lbarone's password:
  JMC\Domain Admins

I setup the [printers], and [print$] shares, as per the Wiki @
and even set up one printer share - [KM-400]. I can see the printer when I
browse with Windows Explorer to \\Samba, but I cannot connect to it
(Windows cannot connect to the printer. Operation failed with error
0x0000001f). Trying to manage anything through the Print Management utility
yields the original error in the first message.

On Tue, May 30, 2017 at 1:55 PM, Rowland Penny via samba <
samba at lists.samba.org> wrote:

> On Tue, 30 May 2017 13:42:30 -0700
> Luke Barone <lukebarone at gmail.com> wrote:
> > Tried this. Reloaded Samba (and smbd and nmbd, just to be safe). Same
> > issue.
> >
> > Other thoughts?
> >
> Have you tried following the Samba wiki ? :
> https://wiki.samba.org/index.php/Setting_up_Samba_as_a_Print_Server
> Rowland
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list