[Samba] Failed to enumerate objects in the container. Access is denied.

Rowland Penny rpenny at samba.org
Thu Mar 30 14:15:11 UTC 2017

On Thu, 30 Mar 2017 15:52:06 +0200 (CEST)
martin via samba <samba at lists.samba.org> wrote:

> > 
> > great, i will give it a try!
> Hi Louis,
> this worked quite well. I used the native Debian Version 4.2.14.
> May it be possible, that the getent-problem has something to do with
> pam-auth-update? I never did that before.


> there are still two issues:
> 1. The path /home/samba does not yet exist, so all the login-paths
> lead to nowhere. Is it a problem to put the samba shares, except
> profiles and users, to another path? I like to use /fs for shortness.

Where ever you put the share must exist, it will not be created for
You could use '/fs', you will just need to change the 'path =' in the
> 2. The first share I have setup with RSAT as Domain Administrator
> worked like expected. I could see the Users in the security tab and
> change them. I could also change ownership succesfully. But after
> saving it all the others did not work, i see "Failed to enumerate
> objects in the container. Access is denied." again. When changing
> settings for the first share, it was the same. So something happened
> there and it is still not usable.

This sounds like a permissions problem, compare the permissions on the
one that works with the others that don't.

> Any ideas? Where could I look? Would 4.5 help? If so, is the update
> troubleless? Should I do it for the dc's as well?

If you are going to update, you might as well use Louis's  deb's they
work very well.


More information about the samba mailing list