[Samba] Failed to connect host xx on port 135 - NT_STATUS_CONNECTION_REFUSED

osdc at mailbox.org osdc at mailbox.org
Tue Mar 28 14:22:26 UTC 2017

Hello there,

I installed a dc1 using debian jessie-packages strictly following the samba-manual "Setting up Samba as an Active Directory Domain Controller".
I installed a dc2 using debian jessie-packages, also strictly following the manual for "Joining a Samba DC to an Existing Active Directory".

It worked for a few weeks but then it quit working without having changed the setup or making an update. I cannot demote it because it is quite an old samba:

Version 4.2.14-Debian

So I tried to repair it. The problem seems to be, that port 135 cannot be reached.

my smb.conf on dc2

# Global parameters
	workgroup = RUBENS
	netbios name = DC2
	server role = active directory domain controller
        dns forwarder = 
        idmap_ldb:use rfc2307 = yes
	printing = bsd
	printcap name = /etc/printcap

        username map = /etc/samba/user.map

	path = /var/lib/samba/sysvol/museum.rubens.world/scripts
	read only = No

	path = /var/lib/samba/sysvol
	read only = No

The error message is:


root at dc2:~# samba-tool drs showrepl
Failed to connect host on port 135 - NT_STATUS_CONNECTION_REFUSED
Failed to connect host (dc2.museum.rubens.world) on port 135 - NT_STATUS_CONNECTION_REFUSED.
ERROR(<class 'samba.drs_utils.drsException'>): DRS connection to dc2.museum.rubens.world failed - drsException: DRS connection to dc2.museum.rubens.world failed: (-1073741258, 'The connection was refused')
  File "/usr/lib/python2.7/dist-packages/samba/netcmd/drs.py", line 39, in drsuapi_connect
    (ctx.drsuapi, ctx.drsuapi_handle, ctx.bind_supported_extensions) = drs_utils.drsuapi_connect(ctx.server, ctx.lp, ctx.creds)
  File "/usr/lib/python2.7/dist-packages/samba/drs_utils.py", line 54, in drsuapi_connect
    raise drsException("DRS connection to %s failed: %s" % (server, e))


It really does not listen:

root at dc2:~# netstat -tulpan | grep "LISTEN" | grep "135" | wc -l

Why does Samba not listen on port 135 anymore? How can I teach it to start doing it again?

Please help


More information about the samba mailing list