[Samba] samba-tool throws Segmentation fault since 4.6

Johannes Engel jcnengel+samba at gmail.com
Sun Jul 16 18:33:14 UTC 2017

Hi all,

thanks for taking the time for an answer. Let me try to fill in the gaps:
Same error with all commands, a simple "Segmentation fault".
OS is always openSUSE Leap 42.2, packages from Open Build Service 
Spec files for building the package are pretty much the same between 4.5 
and 4.6/4.7. I tried with a fresh install without any smb.conf (Domain 
provisioning), still same error. I have not tested every single command, 
that's why I pointed out a few examples of commands that work and those 
that don't, hoping that someone could recognize a pattern.

What else could I contribute? Python version is the same (2.7.13) as it 
used to be and still works with the build of samba 4.5.

Best regards

Am 16.07.2017 um 20:17 schrieb Marc Muehlfeld:
> Hi Johannes,
> Am 16.07.2017 um 19:46 schrieb Johannes Engel via samba:
>> since Samba 4.6 (holds also for 4.7) samba-tool started throwing
>> segmentation faults on my systems for some operations: This includes
>> e.g. domain join after filling the "questionnaire", ntacl sysvolcheck,
>> drs showrepl etc. Others like testparm seem to work as they used to do.
>> I have filed a bug report (#12682), but no reply so far. Since I am not
>> a python expert, I have no idea where to start debugging. Would you mind
>> to assist?
> I can tell you why nobody responses to your BZ: It's as helpful as
> telling the car mechanic: "Something in my car does sometimes not work.
> Please fix it". ;-)
> Please add more details to the BZ, such as:
> * Do you get the same error for all 3 sub-commands?
> * Provide at least the full output of the commands.
> * OS + version?
> * What else has been changed since it worked the last time?
> * smb.conf
> * AD environment information
> * etc.
> Regards,
> Marc

More information about the samba mailing list