[Samba] samba-tool throws Segmentation fault since 4.6

Marc Muehlfeld mmuehlfeld at samba.org
Sun Jul 16 18:17:03 UTC 2017

Hi Johannes,

Am 16.07.2017 um 19:46 schrieb Johannes Engel via samba:
> since Samba 4.6 (holds also for 4.7) samba-tool started throwing
> segmentation faults on my systems for some operations: This includes
> e.g. domain join after filling the "questionnaire", ntacl sysvolcheck,
> drs showrepl etc. Others like testparm seem to work as they used to do.
> I have filed a bug report (#12682), but no reply so far. Since I am not
> a python expert, I have no idea where to start debugging. Would you mind
> to assist?

I can tell you why nobody responses to your BZ: It's as helpful as
telling the car mechanic: "Something in my car does sometimes not work.
Please fix it". ;-)

Please add more details to the BZ, such as:
* Do you get the same error for all 3 sub-commands?
* Provide at least the full output of the commands.
* OS + version?
* What else has been changed since it worked the last time?
* smb.conf
* AD environment information
* etc.


More information about the samba mailing list