[Samba] DsReplicaSync failed (2, 'WERR_FILE_NOT_FOUND')

Sam Grabowski sam at f1tech.ca
Fri Jul 14 18:49:06 UTC 2017

I have two sites connected via VPN with no firewall rules blocking traffic.
The master site is able to replicate to the second site but the second site cannot replicate back to the master site (with the error below)

On the second DC,
samba-tool drs showrepl
this command shows inbound neighbors just fine but nothing for outbound.
The opposite is true for the master.  It shows the second DC as outgoing but nothing for inbound.

Manual replication commands work fine from the master to the second server but I get an error from the second server back to the master.

ERROR(<class 'samba.drs_utils.drsException'>): DsReplicaSync failed - drsException: DsReplicaSync failed (2, 'WERR_FILE_NOT_FOUND')
  File "/usr/local/samba/lib64/python2.7/site-packages/samba/netcmd/drs.py", line 368, in run
    drs_utils.sendDsReplicaSync(server_bind, server_bind_handle, source_dsa_guid, NC, req_options)
  File "/usr/local/samba/lib64/python2.7/site-packages/samba/drs_utils.py", line 83, in sendDsReplicaSync
    raise drsException("DsReplicaSync failed %s" % estr)

I have looked for a solution but I cannot find the exact same error.  The closest thing I could find was a solution to make sure all servers can resolve and make sure everything is in the hosts file.
I have tested the DNS resolution with success, both servers can successfully resolve either server by host name and by full name including the domain.

Both servers are CentOS7 running Samba 4.6.6 compiled from source.  I have also tried this with Debian9 as the second DC with the exact name result.  Both servers are also using BIND9_DLZ as the DNS backend.

Any ideas would be greatly appreciated as I am struggling to get this replication working back to the master.

Thank you.

More information about the samba mailing list