[Samba] Winbindd crashed on DC

Rowland Penny rpenny at samba.org
Fri Jul 14 13:39:49 UTC 2017

On Fri, 14 Jul 2017 14:52:35 +0200
Christian Naumer via samba <samba at lists.samba.org> wrote:

> Hello all,
> I configured DHCPD on two of my DCs to update the DNS records
> according to the wiki (https://w
> iki.samba.org/index.php/Configure_DHCP_to_update_DNS_records_with_BIND9).
> This works now as expected (see my other post). The script used in
> the wiki (dhcp-dyndns.sh) uses "wbinfo -u | grep dhcpduser" to check
> if the user exists. This worked ok until I reduced the lease time
> from several days to 3h for testing. Then after 1-2 days the winbindd
> component of the DC crashed or something (didn't check what happened,
> nothing in the logs at normal loglevel). This could be seen in that
> no DNS updates were made as the script fails because wbinfo produces
> no output. A restart of the samba-ad restored functionality. This
> happend of both the DCs running the DHCP server but not on the other
> two. Now I have removed the check for the user (no more wbinfo is
> called) as I know it is there. And no crashes of winbindd since then.
> Reducing the lease time to 3 hours is causing dns updates every 1-2
> minutes and in this case also wbinfo -u calls. Should this be
> investigated? Or is this a rare use case?
> Just thought it might help somebody else.
> Regards
> Christian

If you followed the wiki, you should have this in /etc/dhcp/dhcpd.conf:

max-lease-time 1800; # 30 minutes

I don't get the crashes.

I think you should post your dhcpd conf files.


More information about the samba mailing list