[Samba] getent problems with new Samba version

Mark Foley mfoley at ohprs.org
Fri Jan 27 14:01:39 UTC 2017

On Fri, 27 Jan 2017 09:36:24 +0000 Rowland Penny wrote:

> Can you post the script that slackware is using to start Samba and can
> you also check if you have more than one 'samba' binary.


$ find / -mount -type f -name samba -exec ls -l \{\} \;
-rwxr-xr-x 1 root root 72720 2016-12-28 14:25 /usr/sbin/samba

Doubtful an older binary would work. Previously I tried restoring the older 4.2.14 winbindd to
see if that would work better and it failed to run missing an .so file.

Start Script - this is actually the same start script as before the 14.2 upgrade. Either there
was no rc.samba.new, or I deleted it after the Samba upgrade:

# /etc/rc.d/rc.samba
# Start/stop/restart the Samba4 Domain Controller - JMF 20140723
# To make Samba start automatically at boot, make this
# file executable:  chmod 755 /etc/rc.d/rc.samba

samba_start() {
  if [ -x /usr/sbin/samba -a -r /etc/samba/smb.conf ]; then
    echo "Starting Samba:  /usr/sbin/samba"

samba_stop() {
  echo "Stopping Samba"
  killall samba

samba_restart() {
  sleep 2

case "$1" in
  # Default is "start", for backwards compatibility with previous
  # Slackware versions.  This may change to a 'usage' error someday.

> I have downloaded the slackware 14.2 DVD and I cannot find the
> 'doinst.sh' script, but mind you, I cannot find samba either. I think
> you must have upgraded Samba via the slackware package manager. 

Yes I did, but when I first installed Slackware 14.1 from that DVD back in 2014 it certainly
had Samba 4.0.x as I used that to provision my AD/DC -- I did not do a separate download from
either Samba.org or Slackbuilds -- and, unlike Ubuntu and Debian (from the same era), it worked
out-of-the box.  I've been updating Samba quarterly since then. 

Also, I do find samba on the 14.2 DVD in slackware64/n/samba-4.4.4-x86_64-3.txz. See
PACKAGES.TXT at the root of the same DVD.

In this email, I've removed all the testing and discussion bits from this thread, but I'll
insert my final questions from the previous message in case you have some theories or can
otherwise correct my misconceptions:

Some unanswered questions, perhaps you know the answer to ...

How did my domain users get in idmap.ldb in the first place? If ADUC put them there when I
created the account, why did ADUC not put user 'shay' in there?

Given the above, is idmap.ldb necessary? Seems redundant with the information in sam.ldb and
apparently overrides sam.ldb when settings conflict.

In the meantime, I think my problem might be solved given the results of this last experiment
to change user 'mark's xidNumber in imap.ldb.

THX --Mark

More information about the samba mailing list