[Samba] Upgrade of Samba from 4.4.6 to 4.5.4

Matthew Delfino mdelfino.list.samba at KNOCKinc.com
Wed Jan 18 21:46:37 UTC 2017

> On 2017.01.18, at 3:21 PM, Rowland Penny via samba <samba at lists.samba.org> wrote:
> On Wed, 18 Jan 2017 14:57:43 -0600
> Matthew Delfino via samba <samba at lists.samba.org> wrote:
>>> On 2017.01.18, at 2:06 PM, Bob of Donelson Trophy via samba
>>> <samba at lists.samba.org> wrote:
>>> On 2017-01-18 13:41, Rowland Penny via samba wrote:
>>>> OK, I give in, why didn't I get the OPs reply to my post ?
>>>> On Wed, 18 Jan 2017 13:23:16 -0600
>>>> Matthew Delfino via samba <samba at lists.samba.org> wrote:
>>>> On 2017.01.18, at 1:16 PM, Reindl Harald via samba
>>>> <samba at lists.samba.org> wrote:
>>>> Am 18.01.2017 um 20:01 schrieb Matthew Delfino via samba: UPDATE:
>>>> These commands seem to have addressed my problem, but I don't know
>>>> if it's a lame or elegant hack:
>>>> ln
>>>> -s /usr/lib/libwbclient.so.0.13 /usr/lib/x86_64-linux-gnu/libwbclient.so.0.13
>>>> cd /usr/lib/x86_64-linux-gnu/ rm libwbclient.so.0
>>>> ln -s libwbclient.so.0.13 libwbclient.so.0 
>>>> looks extremely dirty and fragile
>>> Yeah. It does. It is.
>>>> people really should really learn to build packages which either
>>>> *cleanly* install far away from the system (/usr/local/) or just
>>>> override distribution packages with a higher internal version
>>>> such packages install any needed symlinks and file as needed and
>>>> whenever you have to enter the command "ln" manually your package
>>>> is wrong
>>>> no idea how to build on Debian, on Redhat systems rpmbuild is not
>>>> hard to learn and works over many years and dist-upgrades without
>>>> issues
>>> Well, it's always worked on Ubuntu before. Maybe my configuration is
>>> just odd enough that I stumbled upon a bug?
>>>> On 2017.01.18, at 12:55 PM, Matthew Delfino via samba
>>>> <samba at lists.samba.org> wrote:
>>>> Hey Rowland, thanks for your quick reply. Answers below...
>>>> On 2017.01.18, at 12:41 PM, Rowland Penny via samba
>>>> <samba at lists.samba.org> wrote:
>>>> On Wed, 18 Jan 2017 11:34:41 -0600
>>>> Matthew Delfino via samba <samba at lists.samba.org> wrote:
>>>> Hello,
>>>> I have an Ubuntu 14.04 server with Samba 4.4.6 and a BIND DLZ
>>>> backend that I've downloaded, configured and installed from
>>>> source. 
>>>> Did you compile Bind9 or use the Ubuntu package, it is not clear
>>>> from what you have posted.
>>> I compile bind9. As I understand it, a download and compile has
>>> been required to get BIND with a DLZ backend on Ubuntu for some
>>> time. I use the sources that Ubuntu provides:
>>> apt-get source bind9 
>>> It has been some time since I used Ubuntu 14.04, but I am fairly
>>> positive that the version of Bind9 that comes with 14.04 works with
>>> Samba.
>>>> When you compiled Samba, How did you configure it ? 
>>>> (login)
>>>> mkdir source
>>>> cd source
>>>> wget
>>>> https://download.samba.org/pub/samba/stable/samba-4.5.4.tar.gz
>>>> tar -zxf samba-4.5.4.tar.gz cd samba-4.5.4/
>>>> ./configure --enable-fhs --prefix=/usr --sysconfdir=/etc
>>>> --localstatedir=/var --enable-debug make
>>>> sudo -s
>>>> service samba-ad-dc stop
>>>> make install
>>> Don't do that (too late now though), you could clobber your version
>>> of Samba if somehow Samba gets installed with apt-get or an update.
>>>> I've downloaded the source for Samba 4.5.4, compiled and
>>>> installed, and now Samba won't launch. 
>>>> Did you configure Samba exactly as the earlier compile.
>>> Yes. Always have been doing this the with the same configure
>>> options.
>>>>> If I try to run samba, I get the following error:
>>>>> samba: /usr/lib/x86_64-linux-gnu/libwbclient.so.0: version
>>>>> `WBCLIENT_0.13' not found (required
>>>>> by /usr/lib/samba/libLIBWBCLIENT-OLD-samba4.so)
>>>>> I see that in /usr/lib/x86_64-linux-gnu/ there is no
>>>>> libwbclient.so.0.13
>>>>> In /usr/lib/ there's a libwbclient.so.0.13
>>>>> Do you think all I have to do is make a soft link
>>>>> in /usr/lib/x86_64-linux-gnu/ pointing
>>>>> to /usr/lib/libwbclient.so.0.13? Or could there be a more
>>>>> elegant solution?
>>>> Possibly not, if you compiled Samba as recommended, it should
>>>> all end up in /usr/local/samba and there should
>>>> be /usr/local/samba/lib/libwbclient.so.0.13
>>> As I said, you wouldn't be having this problem if you had compiled
>>> Samba as shown on the Samba wiki or had created your own deb
>>> packages (or used Louis packages).
>>> You now need to identify just which libwbclient client the complile
>>> created and use this.
>>> Rowland
>>> Yes, Rowland, Ubuntu 14.04 and 16.04 repo packages of Bind9 works
>>> with DLZ modification specified in wiki. (I had 14.04 running in VM
>>> and use Bind9 repository packages in my production environment
>>> running 16.04.1 LTS.)
>> Thank you, everyone, for trying to help. These replies have me quite
>> lost, though. I think you guys are going to let me have it, but I’m
>> really needing help.
>> - I do not understand how my configuration went bad. Was it the
>> options I added to "configure"? I have been using those options since
>> I upgraded from an old version of samba distributed with Ubuntu 14.04
>> that was quite a few updates behind what was current. To get
>> up-to-date, I used those options. They allowed me to overwrite
>> Ubuntu’s Samba and use all the data files I already had in place. No
>> one has attempted to install Ubuntu’s Samba over the compiled version
>> since. It’s worked quite well for many subsequent updates - no
>> issues. Until today, of course.
>> - I base all my actions off of what I read on the samba wiki to begin
>> with. As far as I can tell:
>> https://wiki.samba.org/index.php/Build_Samba_from_Source
>> <https://wiki.samba.org/index.php/Build_Samba_from_Source>, this is
>> basically what I did. Yes, I added some options to configure (because
>> of the reasons above), but do you really think this is what doomed me?
>> - I can compile Ubuntu’s bind from source to include what we need,
>> but Ubuntu’s simplest installation of bind ("sudo apt-get install
>> bind9") is a package that had support for DLZ backend left out.
>> - Bind 9 on an Ubuntu Server 14.04.5 LTS, standard issue:
>> BIND 9.9.5-3ubuntu0.11-Ubuntu (Extended Support Version)
>> <id:f9b8a50e> built by make with '--prefix=/usr'
>> '--mandir=/usr/share/man' '--infodir=/usr/share/info'
>> '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads'
>> '--enable-largefile' '--with-libtool' '--enable-shared'
>> '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr'
>> '--with-gnu-ld' '--with-geoip=/usr' '--with-atf=no' '--enable-ipv6'
>> '--enable-rrl' '--enable-filter-aaaa' 'CFLAGS=-fno-strict-aliasing
>> -DDIG_SIGCHASE -O2' compiled by GCC 4.8.4 using OpenSSL version:
>> OpenSSL 1.0.1f 6 Jan 2014 using libxml2 version: 2.9.1
> Virtually the same as on Debian 8 and I can assure you it works with
> Samba, did you try it ?

You bet I did, but it was a year ago and I cannot tell you exactly what I did and how it failed. I’m sure I did something wrong. 

> Rowland
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

©2017 KNOCK, inc. All rights reserved. KNOCK is a registered trademark of KNOCK, inc. This message and any attachments contain information, which is confidential and/or privileged. If you are not the intended recipient, please refrain from any disclosure, copying, distribution or use of this information. Please be aware that such actions are prohibited. If you have received this transmission in error, kindly notify the sender by e-mail. Your cooperation is appreciated.

More information about the samba mailing list