[Samba] (DeviceIoControl, FSCTL_SET_SPARSE)

noid at wolfdogg.org noid at wolfdogg.org
Tue Feb 14 03:16:13 UTC 2017


Im having an issue with what I believe might be pinned down to a need for a
proper samba configuration. 


The problem: sparse writes (not sure which, either write sparse files to a
system that doesn't support them, or vice versa)


The system:

Zfs-on-linux, samba share


Accessing system which is erroring:

Win7x64_ult, freefilesync


Error message


NOTHING I have done to it is fixing, including 

strict allocate = yes

strict allocate = no

share:fake_fscaps = 0

#share:fake_fscaps = 0


Current samba config:


    #security = user

    #passdb backend = tdbsam


                workgroup = MYGROUP

                #strict allocate = yes


                #kill printing

                printing = bsd

                printcap name = /dev/null

                load printers = no


    disable spoolss = yes


    #aim to fix windows freefilesync copy symlinks not working

                #follow symlinks = yes

    #wide links = yes


    #another zpool implemention style testing with, didnt help

    #usershare path = /san/vault

    #max shares = 0 is disabled

    #usershare max shares = 100

    #usershare allow guest = no

    #share:fake_fscaps = 0



                comment = Home Directories

                valid users = %S, %D%w%S

                browseable = No

                read only = No

                inherit acls = Yes



    comment = ZFS 'san' pool Backup File Server

    path = /san/vault

                #share:fake_fscaps = 0

    #ironically doesnt make it readonly, however, worked in favor of
writeabe, valid users, and browseable yes, on arch

    #read only = yes

    write list = @sys1


Writing is done on windows machine to this path, non mapped



Reference urls




same problem, now on rhel7.3, followed me from an archx64 system, same pool


Note, I tried last night to create instead a sparse vol, and mount it after
mkfs an ext3 filesystem on there, I didn't map to it separately using samba,
but I did a test write to that dir, and still, same problem.  I didn't know
how feasible it was to actually think that a sparse vol, would solve a
sparse file write issue, but it was worth a try to me. 


Any ideas, ideals a proper samba config that will fix this in one shot, are
warmly welcomes, I have TB's of data hanging on a thread, getting a bit
scattered, and causing a lot of other drives to have to suffer high head
writes because of it.  One failure and im on a downhill slide.  Time is of
the essence.  I have already persued a ZFS driver issue / bug path, a
FreefileSync issue / bug path, and now im out of options I think, unless its
just the way I mounted or created my pool, OR what I suspected a bad
Property on ZFS, or the samba config.  




More information about the samba mailing list