[Samba] Samba share not appearing in Windows version 1709

Gerard Seibert gerard_seibert at outlook.com
Sun Dec 17 10:26:20 UTC 2017

I am running samba 4.6.11 of a FreeBSD 11.1 machine. This machine is part of a
mixed network. I just updated one of the machines to the Windows 10 Fall
Creators Update, version 1709. Now, the samba enabled machine no longer
appears in the "Network" on the MS Machine; although I can reach it by
manually typing in its network address, "\\Net_Bios_Name".

I got this from the Microsoft knowledge base:

SMBv1 is not installed by default in Windows 10 Fall Creators Update and
Windows Server, version 1709 Applies to: Windows 10 version 1709, Windows
Server Datacenter Core, version 1709, Windows Server Standard Core, version

A complete description of the problem is listed on the site:

I added this to the smb4.conf file: client min protocol = SMB2. Obviously, I
restarted samba after makeing the change. I even did a cold reboot of the
machines thinking that might have an affect. It didn't.  I also tried som
variants, like SMB3, but still no change.

I also noticed that running "testparm" does not show that entry in the
[global] section of the config file. Why is that? I am entering the parameter
incorrectly or in the wrong section?

Thanks for any assistance you can afford me.


More information about the samba mailing list