[Samba] Windows 98 cannot connect to Samba 3.6.23-45el6 after upgrade from 3.0.33-3.41.el5

Justin Cantrell cantrell at astro.gsu.edu
Mon Dec 11 21:25:35 UTC 2017

On 12/11/2017 04:18 PM, Andrew Bartlett via samba wrote:
> On Mon, 2017-12-11 at 15:49 -0500, Justin Cantrell via samba wrote:
>> I upgraded a server from CentOS 5 to CentOS 6 and migrated the samba
>> users, accounts, and files. Everyone reconnected without a problem
>> except a Win98 user.
>> Is there anything that changed that would disallow a Win98 machine from
>> connecting.
>> It doesn't prompt for password.  It just doesn't connect.
>> When attempting to map the drive, I get:
>> "The following error occurred while trying to connect S: to \\server\folder
>> The computer or sharename could not be found. Make sure you typed it
>> correctly and try again."
>> No entries in /var/log/messages /var/log/samba/smb.log /var/log/secure
>> I can connect on the same subnet with Windows 10 machines using the same
>> credentials.
> My first guess is that you need to set:
> lanman auth = yes
I have tried this. It didn't do anything
> Naturally this isn't secure, but this is most likely what the issue is.
> If not, turn up the logs and see what more detail you can get.  3.6
> still uses SMB1 only by default (and this is still on by default even
> in modern versions), so it won't be the new SMB2 world.
I tried log level 2. It gave no indications. I guess I'll go higher.
> I hope this helps,
> Andrew Bartlett

More information about the samba mailing list