[Samba] Unable to add a particular member to group (Samba 4.6.3)

Rowland Penny rpenny at samba.org
Fri Apr 28 14:04:13 UTC 2017

On Fri, 28 Apr 2017 09:41:31 -0400
Luc Lalonde <Luc.Lalonde at polymtl.ca> wrote:

> Hello Rowland,
> Have you tried deleting a user, re-creating the same user and then
> try to add him to a group?
> I'm convinced that this will point us in the right direction to
> correct the bug.

Yes and to confirm it, I just did it again:

samba-tool user create User2 passw2rd* --given-name=Jane --surname=Doe
User 'User2' created successfully

samba-tool user delete User2
Deleted user User2

samba-tool user create User2 passw2rd* --given-name=Jane --surname=Doe
User 'User2' created successfully

samba-tool group addmembers wingroup User2
Added members to group wingroup

dn: CN=wingroup,CN=Users,DC=testing,DC=tld
objectClass: top
objectClass: group
cn: wingroup
instanceType: 4
whenCreated: 20170428115757.0Z
uSNCreated: 3776
name: wingroup
objectGUID: 251d7f63-0da9-4c4f-b4fc-4419c565318d
objectSid: S-1-5-21-1674337020-2794997694-142666819-1103
sAMAccountName: wingroup
sAMAccountType: 268435456
groupType: -2147483646
objectCategory: CN=Group,CN=Schema,CN=Configuration,DC=testing,DC=tld
member: CN=Jane Doe,CN=Users,DC=testing,DC=tld
whenChanged: 20170428135214.0Z
uSNChanged: 3792
distinguishedName: CN=wingroup,CN=Users,DC=testing,DC=tld

I cannot confirm your problem, I can create a user and add it to a
group, I even tried it with the username that doesn't work for you and
it worked for me. I am beginning to think it might be easier to get
your user to change their name ;-)

I think it may be a locale problem, what locale are you using ?


More information about the samba mailing list