[Samba] Unable to add a particular member to group (Samba 4.6.3)

Rowland Penny rpenny at samba.org
Tue Apr 25 15:50:26 UTC 2017

On Tue, 25 Apr 2017 10:36:54 -0400
Luc Lalonde via samba <samba at lists.samba.org> wrote:

> Hello Folks,
> I'm getting this strange error when I try to add a particular member
> to a group:
> [root at roquefort admin]# /usr/local/samba/bin/samba-tool group
> addmembers foogroup foouser
> ERROR(exception): Failed to add members "foouser" to group "foogroup"
> - Unable to find "foouser". Operation cancelled.
>    File 
> "/usr/local/samba/lib64/python2.6/site-packages/samba/netcmd/group.py", 
> line 239, in run
>      add_members_operation=True)
>    File
> "/usr/local/samba/lib64/python2.6/site-packages/samba/samdb.py", line
> 274, in add_remove_group_members raise Exception('Unable to find
> "%s". Operation cancelled.' % member)
> However, it seems to work for another account:
> [root at roquefort admin]# /usr/local/samba/bin/samba-tool group
> addmembers foogroup foouser2
> Added members to group foogroup
> [root at roquefort admin]# /usr/local/samba/bin/samba-tool group 
> removemembers foogroup foouser2
> Removed members from group foogroup
> Anyone have an idea what's causing this?   I even tried to re-create
> the 'foouser' account and I get the same error.

Does the user exist in AD ?
If you run 'wbinfo -u | grep foouser' do you get any output ?
Does 'samba-tool user list | grep foouser' show the user ?

If the user does exist in AD, then I suggest you compare the 'foouser'
object in AD with the object for 'foouser2' 


More information about the samba mailing list