[Samba] Multichannel working at half speed with 2x NICs

Jeremy Allison jra at samba.org
Wed Sep 28 19:00:51 UTC 2016

On Wed, Sep 28, 2016 at 05:56:24AM +0000, Kanchana Marasinghe via samba wrote:
> Similar to another thread that was posted recently (archive:
> https://groups.google.com/forum/#!topic/linux.samba/sRvmCb25U_s) I'm trying
> to get multichannel working with a virtual Linux server running version
> 4.4.5.
> Output of 'uname -a': "Linux filehost 4.4.0-38-generic #57-Ubuntu SMP Tue
> Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux"
> I have two VirtIO NICs on my server that I've confirmed works at at least 1Gbps
> (via iperf) to my Windows 10 client which also has 2 1Gbps NICs. Since virtio
> interfaces dont seem to report link speeds, I've changed my smb.conf to
> reflect this as such:
> "interfaces =;speed=1000000000;speed=1000000000"
> I've also tried with and without "aio read size = 1" and "aio write size =
> 1", but that didn't change anything. In addition, I've tried all the
> suggestions in thread linked above and all have been unsuccessful.
> I've verified that all my drives on both the server and client are capable
> of sustaining read/writes of well over 250MB/s, so I don't think this is a
> disk bottleneck issue.
> What happens during a file transfer is that both interfaces are only
> utilized at around 50%, so they both combine to give me ~1Gbps, when they
> really should be working at 100% each for ~2Gbps total.
> What can I do to troubleshoot this?

strace the connected smbd to ensure it's using the pthreadpool.

More information about the samba mailing list