[Samba] upgrading to 4.4+

yabko yabkopl at yahoo.com
Wed Sep 14 00:45:44 UTC 2016

hi bringing this thread back to life

i waited to ugprade to 4.5.0

and after installing it i get a lot the same errors for users and computers
objects when runnung

samba-tool dbcheck --cross-ncs

Checked 4744 objects (4909 errors)

ERROR: unsorted attributeID values in replPropertyMetaData on
Not fixing replPropertyMetaData on

CN=USER1,OU=Users,OU=123,OU=MAINOU,DC=DOMAIN,DC=MY: 0x00000000
ERROR: incorrect attributeID values in replPropertyMetaData on

Not fixing incorrect value 0x002a0001 with 0x97b17421 for zarafaAdmin in
replPropertyMetaData on CN=USER1,OU=Users,OU=123,OU=MAINOU,DC=DOMAIN,DC=MY

and there's lots of them

after applying the --fix

rerunning the command gives

Checked 4744 objects (315 errors)

and another check shows that 

unable to find object for DN CN=USER2,OU=Users,OU=1968 205
OB,OU=MAINOU,DC=DOMAIN,DC=MY - (No such Base DN: CN=USER2,OU=Users,OU=1968
Not removing dangling forward link

and the --fix flag won't remove those links

and also after the initial fix i cannot authenticate to zarafa, so some
properties are broken that worked prior to upgrading, my zarafa config looks
similiar to yours. and the most strange thing is that it worked prior to

View this message in context: http://samba.2283325.n4.nabble.com/upgrading-to-4-4-tp4706380p4708029.html
Sent from the Samba - General mailing list archive at Nabble.com.

More information about the samba mailing list