[Samba] Can't access to \\ip and some cname after migration from samba 3 to samba 4.4.5

Trenta sis trenta.sis at gmail.com
Sun Oct 30 19:08:23 UTC 2016


I'll try to give information asked in preious messages:
- We have only one samba Domain controller and one dns (bind in same samba
- Our domain doesn't have any .local
- avahi is not running and we use debian lenny
- This is a samba 4 AD domain, migrated form samba 3 nt domain using
classic upgrade as it is described in samba wiki
- problem is reported in lan network, is not a remote user
- Detected that for some users work in same machien taht on other is not
working, searched differences, but wihout success...

Not sure about message smb2, I think that is not the problem is a windows
2003 server and smb2 is not used in windows 2003... I think...

Any suggestions about what bould be the problem?


2016-10-27 22:40 GMT+02:00 Trenta sis <trenta.sis at gmail.com>:

> hi,
> error message when we try to connect with \\IP with dc available "no
> network provider accepted the given network path"
> 2016-10-27 22:34 GMT+02:00 Trenta sis <trenta.sis at gmail.com>:
>> hi rowland,
>> after migration one of past migration tasks were generare reverse zone
>> and add alla and ptr manually.
>> I have made some additional tests and seemsthat if we shutdown samba
>> domain controller or  disconnect network then we can access with \\ip with
>> two domain members server, and then if we reconnect network in samba ad
>> server we reproduces error with \\ip
>> any solution?
>> thanks
>> 2016-10-26 17:53 GMT+02:00 Trenta sis <trenta.sis at gmail.com>:
>>> Hi,
>>> Recently we have migrated from samba 3 nt domain to samba 4 AD (4.4.5)
>>> and we have detected that some applications are not working correctly, this
>>> applications need to access to \\ip resource, with name works, but we have
>>> some applications that needs to work only by ip
>>> Also detected this problem with some cname in dns are not responding we
>>> use bind9 + dlz, and we if we access from \\name works... what could be the
>>> problem... I have tried to update windows (windows 2003) to latest updates,
>>> reinstall some updates that can generate the problems but without success..
>>> and I don't know how to solve this issue
>>> For problems with cname and some name seems that if in LOGON machines
>>> (allowed) we define only some machine then some cname fails, tried to add
>>> samba server, \\cname... without success, only if we disable logon machines
>>> (allow all) then this works...
>>> About \\ip any workaround is found... any solution?
>>> Before migration all was working correctly, and we doesn't have added
>>> any gpo or any other special change, only migrat from samba nt to samba 4
>>> ad 4.4.5...
>>> Anybody can help with both errors?
>>> Thanks

More information about the samba mailing list