Ryan Ashley ryana at reachtechfp.com
Fri Oct 28 00:49:04 UTC 2016

Bigger problem now. I tried getting the domain SID.

root at dc01:~# net getlocalsid
Can't fetch domain SID for name: DC01

It appears to me that SIDs are not resolving at ALL. How can I fix this?
I am back on 4.5.1 again, fresh domain on a fresh install.

Lead IT/IS Specialist
Reach Technology FP, Inc

On 10/27/2016 08:15 PM, Ryan Ashley via samba wrote:
> OK, I am both panicked and lost now. I stopped Samba, uninstalled,
> removed the source directory, removed every Samba directory on the
> system (/var/lib/samba, /var/log/samba, /var/cache/samba,
> /var/run/samba, /usr/lib/python2.7/dist-packages/samba), rebooted,
> cloned 4-5-stable, configured, built, installed, provisioned a new
> domain, and this is what I get. I am following the guide to the letter.
> root at dc01:~# smbclient -L localhost -U administrator
> Enter administrator's password:
> session setup failed: NT_STATUS_INVALID_SID
> So what in the heck is going on? I have no firewall on this system, so
> RPC should not be blocked.
> Lead IT/IS Specialist
> Reach Technology FP, Inc
> On 10/27/2016 06:49 PM, Arthur Ramsey via samba wrote:
>> Try using 4.4.5 vanilla or 4.5.1 with the patch attached.  I don't you
>> need to restore, but that's your call.  I had the same problem as you
>> and either fixed it for me.
>> Thanks,
>> Arthur
>> On 10/27/2016 05:10 PM, Ryan Ashley via samba wrote:
>>> OK, I have now tried three versions of Samba and all react the same way.
>>> This tells me that I physically have an issue with a database or
>>> something. Is it going to be faster for me to simply wipe the entire AD,
>>> restore my Windows Server clean install image, and start over? I have
>>> until midnight to make this work. It is 1810hrs now.
>>> Lead IT/IS Specialist
>>> Reach Technology FP, Inc
>> This e-mail and any attachments may contain CONFIDENTIAL information,
>> including PROTECTED HEALTH INFORMATION. If you are not the intended
>> recipient, any use or disclosure of this information is STRICTLY
>> PROHIBITED; you are requested to delete this e-mail and any attachments,
>> notify the sender immediately, and notify the Mediture Privacy Officer
>> at privacyofficer at mediture.com.

More information about the samba mailing list