[Samba] Error joining Linux member to 4.5.0 DC: Indicates the SID structure is not valid

Arthur Ramsey arthur_ramsey at mediture.com
Wed Oct 26 19:16:08 UTC 2016

On 10/21/2016 11:05 AM, Vinicius Bones Silva via samba wrote:
> I've had this problem as well. We created a domain with two 4.4.4 DCs 
> and everything worked. Sometime after we upgraded the DCs to 4.5.0, 
> the machine joins and some user logons displayed the invalid SID 
> message. We tried recreating the domain from scratch with 4.5.0, but 
> had the same problem. We recreated everything with 4.4.4 , and did not 
> have problems so far. 
Vinicius, any chance you could try my patch to help confirm the findings?


This e-mail and any attachments may contain CONFIDENTIAL information, including PROTECTED HEALTH INFORMATION. If you are not the intended recipient, any use or disclosure of this information is STRICTLY PROHIBITED; you are requested to delete this e-mail and any attachments, notify the sender immediately, and notify the Mediture Privacy Officer at privacyofficer at mediture.com.

More information about the samba mailing list