[Samba] samba v4-5-stable build fails

Cobra Koral cobrakoral at hotmail.com
Wed Oct 5 22:10:41 UTC 2016

Hello guys.

I am trying to compile samba from git repository, branch v4-5-stable, and I got this error during ./configure

Checking for perl $Config{vendorprefix}:                                          : '/usr'
PERL_ARCH_INSTALL_DIR:                                                            : '${LIBDIR}/perl5'
PERL_LIB_INSTALL_DIR:                                                             : '${DATADIR}/perl5'
Traceback (most recent call last):
  File "./buildtools/bin/waf", line 76, in <module>
    Scripting.prepare(t, cwd, VERSION, wafdir)
  File "/home/israelm/Projects/samba/third_party/waf/wafadmin/Scripting.py", line 145, in prepare
    prepare_impl(t, cwd, ver, wafdir)
  File "/home/israelm/Projects/samba/third_party/waf/wafadmin/Scripting.py", line 135, in prepare_impl
  File "/home/israelm/Projects/samba/wscript", line 347, in main
  File "./buildtools/wafsamba/samba_wildcard.py", line 110, in wildcard_main
  File "/home/israelm/Projects/samba/third_party/waf/wafadmin/Scripting.py", line 241, in configure
  File "/home/israelm/Projects/samba/third_party/waf/wafadmin/Configure.py", line 237, in sub_config
    self.recurse(k, name='configure')
  File "/home/israelm/Projects/samba/third_party/waf/wafadmin/Utils.py", line 656, in recurse
  File "/home/israelm/Projects/samba/wscript", line 103, in configure
  File "./buildtools/wafsamba/samba_perl.py", line 52, in SAMBA_CHECK_PERL
ValueError: list.remove(x): x not in list

Seems like it is trying to remove a value which is not in the list ?
This happened during PERL environment setup.
So I tried removing the line 52 on the file

and it just worked.
I haven't installed yet, but as the compile error didn't spit any error, I am guessing the PERL environment was found and compilation worked.

My environment is a GNU/Linux debian 9 testing with nothing else installed, did a netinstall.
I did check https://wiki.samba.org/index.php/Operating_system_requirements/Dependencies_-_Libraries_and_programs
and installed all the dependencies.

Should I open a bug ?
Can someone advise on that please ?

Thanks a lot

More information about the samba mailing list