[Samba] Disk size on share with multiple partitions

Jochen Eggemann Jochen.Eggemann at nw-fva.de
Wed Nov 16 14:02:20 UTC 2016

Am 15.11.2016 um 13:00 schrieb Volker Lendecke:
> On Tue, Nov 15, 2016 at 12:25:32PM +0100, Jochen Eggemann via samba wrote:
>> Hi list,
>> I am exporting share which has a small base partition into which several
>> much larger partitions are mounted. Which are used by different user groups.
>> My problem is, that windows takes the size of the base partition to be the
>> size of the whole share.
>> If I try to copy anything larger than the base partion into a partition that
>> is actually larger Windows reports insuffient disk size for the copy
>> operation and quits. I can copy when I use chunks under the size of the base
>> partition.
>> Is there any possibiity to overcome that problem, or do I have to make 1
>> large partion and use quotas.
> Use the "dfree command" and "dfree cache time" to accumulate the
> space.
> Volker

Thanks for the fast reply Volker,

I tried using this, but get following Errors:

../source3/lib/system.c:1143(sys_popen) sys_popen: ERROR executing 
command '/usr/bin/dfree .': Fehler im Format der Programmdatei (Error in 
format of program file)
../source3/smbd/dfree.c:117(sys_disk_free) disk_free: file_lines_load() 
failed for command '/usr/bin/dfree .'. Error was : Keine Kind-Prozesse 
(no child processes)

This is on Ubuntu 16.04 using Sernet Samba 4.4.7-SerNet-Ubuntu-20.xenial

I get this no matter what I put into the shell script. I even tried 
putting: echo number number into the file

Any ideas?

More information about the samba mailing list