[Samba] STATUS_INVALID_PARAMETER for printer trying to connect to smb share

L.P.H. van Belle belle at bazuin.nl
Tue Nov 15 13:39:49 UTC 2016

Hai John, 

Can you try the folling for you printer. 
I had a same problem here. 

It worked by useing the follwing to connect to my share. 

You tried :  PCEDOM\printers 
Now try  : .\printers 

And have you tried PCEDOM\Administrator
And try .\Administrator also.

And last, the server your scanning to, if above does not work. 
Add  "ntlm auth = yes"  to the smb.conf 

( optional : raw NTLMv2 auth = yes ) 
Try ones at a time. 

This should work, im having TA5002 and TA3511 and M3540. 
all connected to my samba share.  ( as .\Administrator ) 
The ACL on the folders makes sure for the correct rights for the users. 

Last, asumming you already checked, if you printer has the latest firmware. 

Best regards, 


> -----Oorspronkelijk bericht-----
> Van: samba [mailto:samba-bounces at lists.samba.org] Namens John te Bokkel
> via samba
> Verzonden: dinsdag 15 november 2016 14:21
> Aan: samba at lists.samba.org
> Onderwerp: Re: [Samba] STATUS_INVALID_PARAMETER for printer trying to
> connect to smb share
> On 14 November 2016 at 14:58, John te Bokkel <tanj.tanj at gmail.com> wrote:
> >
> > I have a kyocera TA-205C printer that is can scan to pdf and place the
> file on a smb share.
> >
> > I have a user on my domain (PCEDOM\printers) that can login and access
> the share. I tested it out with smbclient and was able to create a file
> where the printer is supposed to be able to put the file.
> >
> > The printer gave a very unhelpful error message, so I did a packet
> capture to find the error. (see attached)
> >
> > It seems to be with the login, but I know the password is correct. (Copy
> and pasted it for the printer settings and testing with smbclient). I have
> tried the username with and without the domain.
> >
> > Server is 4.5.1 an ad dc and also serving files. I had this working with
> 4.3.5, but I had to rebuild my server when the upgrade to 4.5.1 happened
> so I'm not sure if I'm just missing a setting somewhere.
> >
> > If this is a setting, where should I be looking?
> OK,
> I took the login part out of the equation and set permissions on the
> share to allow Full Control to Everyone on that folder.
> This is what the sequence looks like now.
> Client: NBSS Session request
> Server: NBSS Positive session response
> Client: SMB Negotiate Protocol Request.
> Requested Dialects
>     Dialect: PC NETWORK PROGRAM 1.0
>     Dialect: MICROSOFT NETWORKS 1.03
>     Dialect: MICROSOFT NETWORKS 3.0
>     Dialect: LANMAN1.0
>     Dialect: LM1.2X002
>     Dialect: DOS LANMAN2.1
>     Dialect: Samba
>     Dialect: NT LANMAN 1.0
>     Dialect: NT LM 0.12
> Server: SMB Negotiate Protocol Response
> Capabilities: 0x0080f3fc, Unicode, Large Files, NT SMBs, RPC Remote
> APIs, NT Status Codes, Level 2 Oplocks, Lock and Read, NT Find, Dfs,
> Infolevel Passthru, Large ReadX, Large WriteX, UNIX
> It seems the printer doesn't like the response because it closes the
> connection with TCP [FIN, ACK]
> Any insight on why the requested dialects and the corresponding
> response would cause the printer to error?
> Regards,
> John
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/options/samba

More information about the samba mailing list